Get in touch
Back
Degraded

Degraded performance

Started 2 Mar at 06:22pm GMT, resolved 2 Mar at 10:54pm GMT.

https://sellup.herokuapp.com/
Resolved

SellUp has returned to acceptable operation.

Load times may still be affected for the next 1-2 hours.

Posted 2 Mar at 10:54pm GMT.
Created

SellUp is currently experiencing degraded performance.

We have notified our service provider and are awaiting an update.

Posted 2 Mar at 06:22pm GMT.